Technical Support at UW-La Crosse Online

UW-La Crosse Online students are expected to be familiar with computers, the Internet and e-mail. The following are recommended systems and web browsers needed for online courses.

Your Computer

  • PC: Windows 98, ME, 2000, 2003, XP, or Vista (a Pentium or equivalent processor)
  • Macintosh: Mac OS X (up to 10.4)
  • A modem or other device capable of connecting to the Internet at a speed of at least 56 Kbps (DSL or Cable Modem recommended)

Internet Browser

  • Firefox 1.5 or higher
  • Netscape 7.2 or higher
  • Internet Explorer 6.0 or higher
  • Mozilla 1.7 or higher
  • Safari 1.3 or higher

Online Course Management (Desire2Learn)

  • You can see if your computer is configured properly for Desire2Learn by doing a System Check
  • Most internet browsers are supported, but Internet Explorer and Netscape are recommended
  • Make sure that the browser is set to accept cookies (from both 1st party and 3rd party)
  • JavaScript must be enabled
  • Sun Java Runtime Environment (JRE). JRE v.1.4.2.x or JRE 1.5.0.x (recommended) are supported and are required for the Equation Editor

Software

  • Up-to-date virus protection software 
  • An e-mail account; Note: Ensure mail from UW-La Crosse is not automatically blocked
  • Word processing software; Some classes may have specific requirements for additional software. These requirements will be listed in the course syllabus

For questions or support, please visit our Technology Resource Center Web site or the ITS Support Center Web site.